CCIE RS – L3 Tech – EIGRP for IPv4 and IPv6

EIGRP for IPv4 and IPv6

EIGRP

  • Utilizes 50% of the bandwidth
  • DUAL algorithm for shortest path the destination
  • Distance vector protocol
  • Protocol 88
  • Builds a topology table for each of its neighbor advertisements
    • Converges looking for a loop-free router in the topology table
    • Doesn’t know other route and queries its neighbors

 

Neighbor discovery and maintenance

  • Only sends updates about paths that have changed when the paths change
  • Hellos sent every 5 seconds on high bandwidth links and 60 seconds on low bandwidth multipoint links
    • Hold time is 3x the hello by default
      • 15 seconds and 180 seconds
    • Commands – Per Interface
      • ip hello-interval eigrp
      • Ip hold-time eigrp
  • Neighbors are not built over secondary addresses

Metrics

  • Bandwidth and delay are the default metrics used to determine the value to the destination
  • K1=1, K2=0, K3=1, K4=0, K5=0
  • Metric = bandwidth + delay

 


Describe Packet Types

Packet types (hello, query, update, and such)

Hello

  • Used by neighbor discovery and recovery
  • Multicast
  • Unreliable delivery

Acknowledgement

  • ACKs
  • Hello packet with no data
  • Always sent unicast
  • Unreliable delivery
  • If not received after 16 transmissions the neighbor is considered dead
  • RTO – Retransmission Timeout
  • RTO is calculated from the SRTT – Smooth Round Trip Time

Updates

  • Convey route information
  • Sent only when necessary
  • Contain only necessary information
  • When requested by single router, sent unicast
  • When requested by multiple routers, send multicast
  • Always reliable delivery

Queries and Replies

  • Used by DUAL
  • Queries can be multicast or unicast
  • Replies are unicast
  • Use reliable delivery

Route types (internal, external)

Internal

  • Routes originated within the AS
  • AD of 90

Summary

  • Routes that are summarized in the router
  • AD of 5

External

  • Routers that are redistributed into EIGRP
  • AD of 170

 


Implement and troubleshoot neighbor relationship

Neighbor table

Multicast, unicast EIGRP peering

Multicast

  • Default neighbor discovery
  • 224.0.0.10 — 0100:5e00:000a

Unicast

  • Use neighbor command

OTP point‐to‐point peering

Point-to-Point Peering: Point-to-point offers the simplest form of configuration within OTP, and allows OTP to form a peer with a targeted router. This option is controlled by the additional “remote” keyword on the neighbor statement. Once the configuration has been entered, EIGRP will begin sending Hello messages to the address specified. When a Hello message is likewise received from the proper address, routes will then be exchanged.

OTP route‐reflector peering

Route Reflector Peering: If the network has many sites, then OTP offers Route Reflectors (RRs) to form a half-mesh topology and ensure connectivity among all sites in the network. A Route Reflector is an EIGRP peer that receives route updates from remote sites and “reflects” the routes to other sites. Route Reflectors are configured using the keyword “unicast-listen”. This option enables the Route Reflectors to listen for unicast Hello messages from other sites, and upon receiving the first Hello message, automatically forms a peering relationship. OTP supports the use of dual or multiple Route Reflectors for redundancy.

OTP multiple service providers scenario

Site Redundancy: The add path support feature enables hubs to advertise multiple best paths to connected sites. A typical OTP deployment would consists of dual hubs (for hub redundancy) connected to more than one service provider (for service-provider redundancy) and provides up to four additional paths to connected sites. This option is configured using the “add-paths” configuration under EIGRP. If, for example there are two spokes (spoke-1 and spoke-2) at a site, and add-path is configured on the hub, both spoke-1 and spoke-2 will be advertised to other sites, thereby allowing for both redundancy (in the event of lost of connectivity to one of the spokes) and load balancing traffic to spoke-1 and spoke-2

https://www.cisco.com/c/en/us/products/collateral/ios-nx-os-software/ip-routing/whitepaper_C11-730404.html


Implement and troubleshoot loop free path selection

Feasible Distance

  • Best metric along a path to a destination
  • Includes metric to the neighbor advertising the path
  • Lowest calcaulated metric to each destination

Reported Distance

  • Total metric along a path to a destination network as advertised by an upstream neighbor

Feasible Successor

  • Path whose reported distance is less than the feasible distance (current best path)
  • Reduces number of diffusing computations that need to be run

Feasibility Condition

  • Condition that is met if a neighbors advertised distance to a destination is lower tha the routers FD to that same destination
  • If met, a neighbors advertised distance to a destination is lower than the routers FD to the same desintation
    • neighbors advertised distance to a destination meets the FC that neighbor becomes the feasible successor for that destination

Successor

  • Router that is one hop closer to a destination
  • Route that is installed into the routing table from the topology table

Classic Metric

  • Supports 32bit metric calculation
  • EIGRP composite cost metric = 256*((K1*Scaled Bw) + (K2*Scaled Bw)/(256 – Load) + (K3*Scaled Delay)*(K5/(Reliability + K4)))
  • Bandwidth and Delay are used by default (K1 and K3)
  • Not scaled for the higher bandwidths in the field today
  • Lowest configurable delay – 10 microseconds

Wide Metric

  • Supports 64bit metric calculations
  • Allows for bandwidths up top 4.2 terabits
  • Cost metric formula was modified
    • Metric = [(K1*Minimum Throughput + {K2*Minimum Throughput} / 256-Load) + (K3*Total Latency) + (K6*Extended Attributes)]* [K5/(K4 + Reliability)]
  • Introduction of a K6 value
  • By default this calculation is used – Composite Cost Metric = (K1*Minimum Throughput) + (K3*Total Latency)

Implement and Troubleshoot Operations

General Operations

  • Protocol-Dependent Modules

    • Has modules for IP, IPX and AppleTalk for specific routing tasks
    • Uses information to pass to DUAL
  • Reliable Transport Protocol (RTP)

    • Manages delivery and reception of EIGRP packets
    • Delivery is guaranteed and packets will arrive in order
    • Cisco propreitary algorithm – Reliable Multicast
      • 224.0.0.10
    • Sends packets on protocol 88
    • Packet Types
      • Hello – used for neighbor discovery and recovery. Multicast and use unreliable delivery (no ack required)
      • Ack – Hello packets with no data. Unicast and use unreliable delivery
        • If not recieved after 16 unicast retransmits, the neighbor is declared dead
        • Retransmission Timeout (RTO) – Time between unicast messages
          • Calculated from Smooth Round trip Time (SRTT). Average elapsed time (ms) between transmission of a packet to neighbor and receipt of acknowledgement
      • Updates – Convey route information, transmitted only when necessary. Always reliable delivery
      • Queries and Replies – Used by DUAL finite state machine to manage diffusing computation. Queries can be multicast or unicast. Replies are always unicast. Both use reliable delivery
      • RequestsNot in use. Packets intended for use in route servers
  • Neighbor Discovery / Recovery

    • Hellos are multicasted every 5 seconds
      • Slower links – unicast every 60 seconds
      • ip hello-interval eigrp
    • Packet includes hold time – max time to wait between hellos.
      • If holddown timer expires the neighbor is delcared unreachable and DUAL informs neighbors
      • Default hold time – 3 times the hello, 15 seconds
        • 180 on slow links
      • ip hold-time eigrp
    • Information from each neighbor is stored in the neighbor table
  • Diffusing Update Algorithm

    • DUAL – replaced Bellmand-Ford algorithm
    • Operations
      • Node detects within finite time the existance of a few neighbors or loss of connectivity with a neighbor
      • All messages transmitted over an operational link are recieved correctly and in proper sequence within finite time
      • All messages, changes in link cost, link failures and new neighbor noticiations are porcessed one at a time within finite time and in order they were detected
      • EIGRP used neighbor discovery for these operations
    • Adjacency – Logical associatation between 2 neighbors over which route information is exchanged.
      • Update contains all routes known by the sending router and the metrics for the routes
      • Each router will calculate a distance based on the distances advertised by the neighbor and the cost of the link to that neighbor
    • Feasible Distance – Lowest calculated metric to each destination
    • Feasibility Condition – If met, a neighbors advertised distance to a destination is lower than the routers FD to the same desintation
      • neighbors advertised distance to a destination meets the FC that neighbor becomes the feasible successor for that destination
    • Concept of FS and FC are central to loop avoidance. FS is always downstream
      • Router would never choose a path that will lead back to itself, that path out have a distance larger than the FD
    • Every destination for 1 or more FS’s will be recorded in a topology table
      • Destinations FD
      • All Feasible successors
      • Each FS advertised distance to a destination
      • Locally calculated distance to destination
      • Interface connected to the network where FS is found
    • Lowest metric is choosen, that route becomes the successor, next-hop router
  • DUAL Finite State Machine

    • Routes should be in a passive state – diffusing computations are not being performed
    • Router will reaccess the list of FS if an input event occurs
      • Change in cost for directly connected link
      • Change is state (up/down) for directly connected link
      • Reception of an update packet
      • Reception of a query packet
      • Reception of a reply packet
    • Local recomputation is performed first
      • If FS with the lowest distance is different from existing sucesssor the FS will become successor
      • If new distance is lower than the FD, the FD will be updated
      • If the new distance is different from existing, update will be sent to all neighbors

Topology Table

  • Topology table is used for which routes get installed into the routing table
  • Shared between neighbors
  • Table includes
    • Lowest bandwidth on the path to destinationupdate
    • total delay
    • path reliability
    • path loading
    • minimum path maximum transmission unit (MTU)
    • feasible distance
    • reported distance
    • route source (external routes are marked)
  • Show ip eigrp topology

Update Query

  • Used to get updated information from a neighboring router
  • debug eigrp packet update query reply

Active, Passive

  • Passive
    • Stable route in EIGRP, no diffusing computation being run
  • Active
    • If no feasible successor can be found in topology table, route changes to active while router runs diffusing computation
    • Route cannot be changed back to passive until:
      • Change the routes successor
      • Change the distance it advertising for the route
      • Change the routes FD
      • Begin another diffusing computation for the route
    • Active timer – 3 minutes
      • If no replies after active timer exprires the route is declared Stuck In Active
      • timers active-time

Stuck in Active (SIA)

  • When a query takes to long to be answered
  • Router that issued the query clears its connection with the router, restarting the neighbor session
  • Avoid with using summary and stub

Graceful Shutdown

 


Implement and Troubleshoot EIGRP Stub

Stub

Stub routing helps improve the stability of the EIGRP network. It can also help reduce resource utilization and simplifies stub device configuration.

Commonly used in hub and spoke networks at the spoke end

Any neighbor that recieved a packet informing it of the stub status will not query the stub router for any routes. This helps reduce the query domain and help prevent routes from going SIA.

Stubs will only advertise specified routes. Stub devices respond to all queries for summaries, connected routers, redistributed static routes, external routes and internal routes with inaccessible.

router eigrp [as]
network [ip] [wildcard]
eigrp stub [receive-only | leak-map | connected | static | summary | redistributed]
router eigrp [name]
address-family ipv4 [as]
 network [ip] [wildcard] 
 eigrp stub [options]
address-family ipv6 [as]
 network [ip] [wildcard]
 eigrp stub [options]

Leak-Map

Leak-maps allow the ability to advertise a more specific route that would have been suppressed by summarization.

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_eigrp/configuration/15-mt/ire-15-mt-book/ire-eigrp-stub-rtg.html


Implement and Troubleshoot Load-Balancing

Equal-cost

EIGRP will load balance 4 equal cost paths into the routing table by default, which are then load balanced.

Using max-paths allows for up to 6 routes to be load balanced

Unequal-cost

EIGRP allows for unequal cost load balancing using the variance command. Variance is a multiplier

Add-path

By default all interfaces are configured with next-hop-self for EIGRP. This default may interfere with the add-path feature. Used with DMVPN networks (hub). Add Path allows for the hub to advetise up to 4 additional best paths connected to spokes

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_eigrp/configuration/xe-3s/ire-xe-3s-book/ire-add-path.html


Implement EIGRP (multi-address) named Mode

Named mode allows for everything about EIGRP to be configured under a single place inside EIGRP configuration mode.

With this named mode, only a single instance of EIGRP needs to be created. It can be used for all address family types. It also supports multiple VRFs limited only by available system resources. One thing to be aware of in regards to the named mode is that configuration of the address-family does not enable IPv4 routing as a traditional configuration of IPv4 EIGRP.

Covert config: eigrp upgrade-cli [eigrp name]

Types of families

5 types of families, IPv4 unicast, IPv4 multicast, IPv4 VRF, IPv6 unicast, IPv6 VRF

R1(config-router)#address-family ipv4 ?
 autonomous-system Specify Address-Family Autonomous System Number
 multicast Address Family Multicast
 unicast Address Family Unicast
 vrf Specify a specific virtual routing/forwarding instance

R1(config-router)#address-family ipv6 ?
 autonomous-system Specify Address-Family Autonomous System Number
 unicast Address Family Unicast
 vrf Specify a specific virtual routing/forwarding instance

IPv4 address-family

This address family can be unicast, multicast and set for global routing table or for a VRF.

This is for all EIGRP IPv4 routing

IPv6 address-family

This address family can be unicast and set for global routing table or for a VRF.

This is for all EIGRP IPv6 routing

https://www.cisco.com/c/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/200156-Configure-EIGRP-Named-Mode.html


Implement, troubleshoot and optmized EIGRP convergence and Scalability

Describe fast convergence requirements

Requires a feasible successor for a backup path to be added if the successor path fails. Summarization and stubs can also help by reducing the query boundary.

Control query boundary

Can be controlled using stub routers or summarization

IP FRR / Fast Reroute (single hop)

Fast Reroute (FRR) is the mechanism that enables traffic that traverses a failed link to be rerouted around the failure. In EIGRP networks, precomputed backup routes or repair paths are known as feasible successors or loop-free alternates (LFAs)

IPv6 is not supported yet

router eigrp [name]
address-family ipv4 unicast [as]
 topology base
 fast-reroute per-prefix [all | route-map]

Summary leak-map

Allows for more specific routes to be advertised that normally would be suppressed by the summary route

Summary metric

By default, summary routes use the lowest metric amoung the existing routes. If this metric changes, the summary route will also be updated.

The summary metric can be manually configured under the EIGRP process

R2(config)#router eigrp 1
R2(config-router)#summary-metric 10.1.0.0/16 10000 200 255 0 1500

 

CCIE RS – Routing Concepts – Implement, optimize and troubleshoot policy‐based routing

Implement, Optimize and Troubleshoot Policy-Based Routing

Policy based routing is being able to manipulate the path of traffic from what is being directed from the RIB.

Typically this is implemented using route maps and match a source of traffic and changing the destination path.

All packets received on an interface with PBR enabled are passed through enhanced packet filters known as route maps. The route maps used by PBR dictate the policy, determining to where the packets are forwarded.

  • Route maps are composed of statements. The route map statements can be marked as permit or deny, and they are interpreted in the following ways
  • If the packets do not match any route map statements, then all the set clauses are applied.
  • If a statement is marked as deny, the packets meeting the match criteria are sent back through the normal forwarding channels and destination-based routing is performed.
  • If the statement is marked as permit and the packets do not match any route map statements, the packets are sent back through the normal forwarding channels and destination-based routing is performed.

For traffic originated outside of the router

interface GigabitEthernet0/1
 ip policy route-map PBR

!
route-map PBR permit 10
 match ip address prefix-list LOOPBACK
 set ip next-hop 2.2.2.2
!

For traffic originated from the router

ip local policy route-map LOCAL_PBR

https://www.cisco.com/c/en/us/td/docs/ios/12_2/qos/configuration/guide/fqos_c/qcfpbr.html

https://www.cisco.com/c/en/us/td/docs/ios/12_2/qos/configuration/guide/fqos_c/qcfclass.html#wpxref35843


Identify and troubleshoot sub-optimal routing

Sub-optimal routing can occur when using PBR as it may be asymetric due to not capturing traffic in both directions. Asymetric routing is when traffic goes out one interface and is recieved back on a different interface. This may not cause a problem in normal cases, but if a firewall which requires state information, this will cause traffic to be dropped.

You can identify this by checking the routing table, cef table and using traceroute to follow the traffic path.

CCIE RS – Routing Concepts – Implement, Optimize and Troubleshoot Manual and Auto Summarization with any Routing Protocol

Implement, Optimize and Troubleshoot Manual and Auto Summarization with any Routing Protocol

Auto Summarization is when a a prefix is automatically summarized at a network boundary to it’s classful prefix. Example, a router changes the prefix 172.16.5.0/24 to 172.16.0.0/16.


RIP

By default RIP will automatically summarize subnet routes into network level routes

router rip
version 2
[no] auto-summary
network x.x.x.x

https://www.cisco.com/c/en/us/td/docs/ios/12_2/iproute/command/reference/fiprrp_r/1rfrip.html

Manual summarization can be done at an interface level. The summary entry will be entered into the RIP database

R1(config-if)#ip summary-address rip 1.1.1.1 255.255.255.0
R1(config-if)#
R1#sh int lo0
Loopback0 is up, line protocol is up 
 Hardware is Loopback
 Internet address is 1.1.1.1/32




R3#sh ip route
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 1.1.1.0/24 [120/2] via 150.1.23.2, 00:00:05, GigabitEthernet0/1
R 1.1.1.1/32 [120/2] via 150.1.23.2, 00:00:12, GigabitEthernet0/1
 2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 150.1.23.2, 00:00:12, GigabitEthernet0/1
 3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
 150.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
R 150.1.12.0/24 [120/1] via 150.1.23.2, 00:00:12, GigabitEthernet0/1
C 150.1.23.0/24 is directly connected, GigabitEthernet0/1
L 150.1.23.3/32 is directly connected, GigabitEthernet0/1
R3#

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_rip/configuration/xe-3se/3850/irr-xe-3se-3850-book/irr-ipsum-adr-rip2.html


EIGRP

Auto summary is enabled in EIGRP by default.

Summary routers are given an administrative distance of 5

https://www.cisco.com/c/en/us/td/docs/ios/12_2/iproute/command/reference/fiprrp_r/1rfeigrp.html

Manual summarization can be performed at any point in the network

R1(config-if)#ip summary-address eigrp 1 0.0.0.0/0 



R3(config-router)#do sh ip route

D* 0.0.0.0/0 [90/3328] via 150.1.23.2, 00:00:08, GigabitEthernet0/1

https://www.cisco.com/c/en/us/td/docs/ios/12_2/ip/configuration/guide/fipr_c/1cfeigrp.html


OSPF

OSPF does not have an auto summaization feature and can only perform summarization at specific points in the network. OSPF requires at an area has a the same database on each router in that area which means summarization can only be done at area borders.

There are 2 types of summarization

Area range – ABR, summarize internal routes as they get passed to another area as a type 3 interarea LSA

Summary address – ASBR, summarize external routes before injecting them into the OSPF domain at type 5 external LSA’s

https://supportforums.cisco.com/t5/network-infrastructure-documents/ospf-inter-area-route-summarization/ta-p/3145113

http://www.ciscopress.com/articles/article.asp?p=2294214&seqNum=3


BGP

BGP has multiple different ways to summarize routes

network w/ static route

Aggregate-address

R1(config-router)#do sh run | s bgp
router bgp 1
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 aggregate-address 1.1.0.0 255.255.0.0
 neighbor 150.1.12.2 remote-as 2
R1(config-router)#

R2(config-router)#do sh ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
 a - application route
 + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 1.1.0.0/16 [20/0] via 150.1.12.1, 00:00:03
B 1.1.1.1/32 [20/0] via 150.1.12.1, 00:00:03
R2(config-router)#
R2(config-router)#

https://learningnetwork.cisco.com/docs/DOC-11817

https://learningnetwork.cisco.com/docs/DOC-11853

CCIE RS – Routing Concepts – Implement and Troubleshoot Loop Prevention Mechanisms

Implement and Troubleshoot Loop Prevention Mechanisms

Loops can occur when you are redistributing bidirectionally at 2 different points in the network

Route Tagging, Filtering

Route tagging is the process of adding an indentifier (tag) to a set of prefixes. This tag can then be called in a route map. The way I map out how to filter routes is pictured below

Screen Shot 2018-03-08 at 7.59.17 PM

Screen Shot 2018-03-08 at 8.01.55 PM

Screen Shot 2018-03-08 at 8.03.12 PM.png

Split Horizon

Split horizon is used by distance vector routing protocols. This prevents a router from sending a route back out an interface that the route was learned from. The only time you would disable this is in a hub/spoke setup where the hub would need to send routes learned back to other spokes.

Route Poisoning

Used by distance vector routing protocols. Once you learn of a route through an interface, advertise it as unreachable back through that same interface

 

 


https://www.cisco.com/c/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp-toc.html#anc9

CCIE RS – Routing Concepts – Implement and Troubleshoot Routing Protocol Authentication

Implement and Troubleshoot Routing Protocol Authentication

Routing protocols can be configured to authenticate their neighbors to add some security to who you’re doing routing with.

 

RIP and EIGRP utilize key chains for authentication and can be configured per interface. The lowest number valid key will be used for authentication and is ordered in a top-down for which key will be used.

RIP Config

RIP can authenticate with text or md5

Do not add the mode if you want to use text authentication

key chain [name]
 key [#]
 key-string [string]
 accept-lifetime [start] {infinite | end-time | duration seconds}
 send-lifetime [start] {infinite | end-time | duration seconds}

interface [interface]
 ip rip authentication key-chain [keychain name]
 ip rip authentication mode md5

EIGRP Config

key chain [name]
 key [#]
 key-string [string]
 accept-lifetime [start] {infinite | end-time | duration seconds}
 send-lifetime [start] {infinite | end-time | duration seconds}

interface [interface]
 ip authentication mode eigrp [as] md5
 ip authentication key-chain eigrp [as] [key-chain]

-------
Named Mode

router eigrp [name]
 af-interface default
 authentication key-chain [keychain name]
 authentication mode [hmac-sha-256 password | md5]

OSPFv2

There are 3 authentication types for OSPF, null, text and md5

  • Null Authentication—This is also called Type 0 and it means no authentication information is included in the packet header. It is the default
  • Plain Text Authentication—This is also called Type 1 and it uses simple clear-text passwords
  • MD5 Authentication—This is also called Type 2 and it uses MD5 cryptographic passwords.
Plain Text

interface [interface]
 ip ospf authentication-key [password]

router ospf [pid]
 area [area] authentication

------

MD5

interface [interface]
 ip ospf message-digest-key [#] [password]

router ospf [pid]
 area [area] authentication message-digest

----
show ip ospf interface [interface]

OSPFv3

OSPFv3 uses IPSec to enable authentication

interface [interface]
 ospfv3   authentication  {ipsec spi} {md5 | sha1}{ key-encryption-type key} | null

ipv6 ospf authentication {null | ipsec spi spi authentication-algorithm [key-encryption-type] [key]}

ipv6 router ospf [pid]
 area [area] authentication ipsec spi [spi authentication-algorithm]  [key-encryption-type] [key]

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_ospf/configuration/15-sy/iro-15-sy-book/ip6-route-ospfv3-auth-ipsec.html

MD5

Key‐chain

EIGRP HMAC SHA2‐256bit

OSPFv2 SHA1‐196bit

OSPFv3 IPsec authentication

CCIE RS – L3 Tech – RIP and RIPng

RIP

Distance vector routing protocol
Hop count for routing metric

  • Max of 15 hops
  • Used to prevent routing loops
    • Split horizon
    • Route poisoning
    • holddown
  • 16 is infinite distance, route is considered unreachable

Hellos sent every 30 seconds

Timers

  • Update
    • 30 seconds
  • Invalid
    • 180 seconds
    • How long a route can be in routing table without being updated
    • After timer expires, routing entry wil be set to 16 and destination marked unreachable
  • Flush
    • 240 seconds
    • Time between route is marked unreachable and removal from the routing table
  • Holddown
    • Started per route entry
    • 180 seconds
    • Used in Cisco’s implementation

No concept of areas or boundaries

RFC 2453

UDP port 520

Multicast – 224.0.0.9

  • Sends entire routing table to all adjacent routers

Version 2 supports classless routing (CIDR)

Authentication – MD5 or text

Supports route tags

Split Horizon

  • Enabled by default
  • Reduce posibility of routing loops
  • Blocks information about routes from being advertised back on the interface they were learned on
  • May need to disable on an interface in hub/spoke scenario
  • Must disable if you want to use secondary addresses

 

Config

router rip
 version 2
 [no] auto-summary
 network [network]
 passive-interface default
 offset-list [acl] [in | out] {offset}
 timers basic [update, invalid, holddown, flush]
 [no] validate-update-source

interface [interface]
 ip rip send version [1 | 2]
 ip rip receive version [1 | 2]
 ip rip authentication key-chain [name]
 ip rip authentication mode [text | md5]
 [no] ip split-horizon

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_rip/configuration/xe-3se/3850/irr-xe-3se-3850-book/irr-rip.html


RIPng

RIP for IPv6. Based on the bellman-ford algorithm.

RFC 2080

Extension of RIPv2. Same hop count rule as RIP for IPv4

No update authentication – relies on the Authentication Header and IP encapsulating security payload

UDP port 521, each router sends and receives on this port for communicating RIPng

Multicast – FF02::9

Requirement – IPv6 routing must be enabled

ipv6 unicast-routing

interface [interface]
 ipv6 enable
 ipv6 rip [name] enable

ipv6 router rip [name]

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipv6/configuration/15-2mt/ipv6-15-2mt-book/ip6-rip.html

CCIE RS – Routing Concepts – Implement and troubleshoot bidirectional forwarding detection (BFD)

Implement and troubleshoot bidirectional forwarding detection (BFD)

BFD – RFC 7419

BFD is a detection protocol designed to provide fast forwarding path failure detection times for all media types, encapsulations, topologies, and routing protocols.

BFD is not tied to any routing protocol. A routing protocol can utilize BFD to held detect neighbor failures faster. Enabled at an interface level. Must be configured on both ends of the link

CEF and IP routing is required on the router

Used to detect faults between 2 nodes connected by a link

  • Low overhead detection on physical media that doesn’t support failure detection
  • 3 way handshake to establish session
  • Supports authentication
  • Must be explicitly configured

Modes

  • Asynchronous
    • Periodically send Hellos between each other
    • If number of packets are not received, session is considered down
  • Demand
    • No hellos are exchanged after session is established
    • Assumed endpoints have another way to verify connectivity

Echo mode is enabled by default, works with asynchronous BFD

Config

interface [interface]
bfd internal [ms] mix-rx [ms] multiplier [interval]
bfd interval 50 min_rx 50 multiplier 5 

router bgp [as]
neighbor [ip] fall-over bfd

router eigrp [as]
bfd all-interfaces

router ospf [pid]
bfd all-interfaces

 


https://www.cisco.com/c/en/us/td/docs/ios/12_0s/feature/guide/fs_bfd.html

https://en.wikipedia.org/wiki/Bidirectional_Forwarding_Detection