CCNA Collaboration – Notes, Chapter 5

CICD – Ch5 – Managing Endpoints and End Users in CME

Users

  • CME has 3 levels of users
    • System Admin
      • Authority of all aspects of CME system and phone features
    • Customer Admin
      • Perform MACD (Move, Adds, Changes, Delete) to phones and users
      • No system level access
    • Phone User
      • Customize aspects of their own phone
      • Speed dial, extension mobility, search user directory
      • Login with username and password

Creating Users

  • System admin
    • Must be privilege level 15
    • Can use CLI
    • GUI – CME built in (no screenshots)
router(config)#

router(config)#hostname CME

CME(config)#username cisco priv 15 password cisco

CME(config)#line vty 0 4

CME(config-line)#login local

CME(config-line)#transport input all

CME(config-line)#exit

CME(config)#int gi0/0

CME(config-if)#ip add 192.168.10.47 255.255.255.0

CME(config-if)#no shut

CME(config-if)#

CME(config-if)#ip http server

CME(config)#ip http secure-server 

% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

CME(config)#

CME(config)#ip http authentication local
  • GUI CME – Customer Admin
    • Configure > System Parameter > Administrators Login Account

 


CME Terminology

  • ephone – ethetnet phone
    • Physical phone hardware
    • How SCCP phones are referenced in the CLI
    • Device type, MAC address
  • ephone-dn – Directory number
    • Number assigned to SCCP phone

Associate user to ephone-dn

  • Provides caller ID for internal calls
  • Builds system directory
  • Presence status monitoring
    • On/off hook, unregistered
  • Applied ephone-dn config to ephone when user logs in with extension mobility

 


CME Phones

  • CME supports SIP and SCCP

Config – CLI

SCCP

SIP

Phone

ephone

voice register pool

Directory Number

ephone-dn

voice register dn

Telephony Config

telephony-service

voice register global

  • Add phone manually with CLI or GUI
  • Can enable Auto Registration
    • Phones automatically get added to CME

 


Home Lab screenshots and CLI

  • Base config has already been shown above or in previous notes. CCP was installed on my Win10 VM.

Configuring CME

CCP CME Feature Setting - Initial.png

CLI sent to router

telephony-service

 no auto-reg-ephone

 exit

New Options that are available

 

CCP CME Enabled - New Options.png

Enabling SIP

 

Screen Shot 2017-07-03 at 10.12.28 AM.png

  
 

CLI sent to router

Enabling VOIP Settings, SIP settings

voice service voip

 allow-connections h323 to h323

 allow-connections h323 to sip

 allow-connections sip to h323

 allow-connections sip to sip

 no supplementary-service h450.2

 no supplementary-service h450.3

 no supplementary-service h450.7

 no supplementary-service sip moved-temporarily

 no supplementary-service sip refer

 sip

  bind control source-interface GigabitEthernet0/0

  bind media source-interface GigabitEthernet0/0

  registrar server

  exit

 exit

Telephony Settings

Enable router to support SIP and SCCP endpoints, set number of phones and extensions router can support

Choose IP address for phones to register with. I used the physical interface. Loopback address can also be used. Must be a static address, DHCP does not work

 

CCP CME - Enable SCCP and SIP Phone Support.png

 

CLI sent to router

telephony-service

 cnf-file location flash:

 exit

voice register global

 mode cme

 source-address 192.168.10.47

 max-pool 25

 max-dn 50

 tftp-path flash:

 create profile

 exit

telephony-service

 create cnf-files

 exit

voice register global

 mode cme

 create profile

 exit

Phone Images

Not included in the chapter, but CME needs the phone firmware loaded on the flash.

Example Output - done from CLI, TFTP image to router

tftp-server flash:SCCP45.9-4-2SR3-1S.loads alias SCCP45.9-4-2SR3-1S.loads

tftp-server flash:apps45.9-4-2ES26.sbn alias apps45.9-4-2ES26.sbn

tftp-server flash:cnu45.9-4-2ES26.sbn alias cnu45.9-4-2ES26.sbn

tftp-server flash:cvm45sccp.9-4-2ES26.sbn alias cvm45sccp.9-4-2ES26.sbn

tftp-server flash:dsp45.9-4-2ES26.sbn alias dsp45.9-4-2ES26.sbn

tftp-server flash:jar45sccp.9-4-2ES26.sbn alias jar45sccp.9-4-2ES26.sbn

tftp-server flash:term45.default.loads alias term45.default.loads

tftp-server flash:term65.default.loads alias term65.default.loads

telephony-service

 load 7945 SCCP45.9-4-2SR3-1S.loads

 create cnf-files

 exit

Creating SCCP Extension and Phone, creating and assigning user to phone

  

CCP - Creating SCCP Extension.png

CCP CME - Creating SCCP Phone and Assigned Ext.png

CCP CME - SCCP Ext User Created.png

CLI sent to router

!PHONE EXT - SCCP

ephone-dn 1 dual-line

 number 2001

 huntstop

 exit

!ADDING PHONE AND USER - SCCP

ephone 1

 mac-address C062.6BD3.33CE

 type 7945

 auto-line

 exit

ephone 1

 username phone1

 button  1:1

 restart

 exit

ephone-dn 1

 name Phone One

 exit

ephone 1

 restart

 exit

Creating SIP Extension and Phone, creating and assigning user to phone

CCP CME - Creating SIP Ext.png

CCP CME - Creating SIP Phone with Ext Assigned.png

CCP CME - Creating SIP User on Phone.png

CLI sent to router

!ADDING PHONE AND USER - SIP

voice register pool 1

 id mac AAAA.BBBB.CCCC

 type 7945

 exit

telephony-service

 create cnf-files

 exit

voice register global

 mode cme

 create profile

 exit

voice register pool 1

 username Phone2 password password

 number 1 dn 1

 restart

 exit

voice register dn 1

 name Phone Two

 exit

voice register pool 1

 restart

 exit

CCNA Collaboration – Notes, Chapter 4

CICD – Ch4 – CME Administration

Overview

  • CCNA Covers configuring CME using CCP (Cisco Configuration Professional)
    • I will include screenshots of the GUI and also show the command line that gets generated
    • CME can also be configured by using it’s own GUI
      • HTML and java based
      • Loaded onto flash with a .tar file
      • Allows add/change of phones, modifying dial plan, configuring hunt groups, etc.
  • CCP configures all major aspects of CME
    • CCP can also be used for LAN, WAN and security features
  • CCP must discover devices before it can configure them
    • Discovery includes finding out information about the hardware, software, interfaces and modules

 

CCP Desktop Icon

 

CCP Device Discovery.png

CCP Device Being Discovered.pngCCP CME Features

  • CUBE – Cisco Unified Border Element
    • Telepohony gateway for IP to IP services
      • Ex: IP-TSP – IP Telephony Service Provision
    • NAT/PAT services
    • Billing, security, call admision control, qos, SIP negotiation
  • CUCME – Standalone CME
  • SRST – Survivable Remote Site Telephony
    • Allows phones to register to router (gateway) if they lose connectivity to CUCM
  • CME as SRST
    • SRST with full CME features

 

CCP CME Feature Setting - Initial.png

CCNA Collaboration – Notes, Chapter 3

CICD – Ch3 – Cisco IP Phone


Foundations

  • IP Phones require the following
    • POE – Power Over Ethernet
    • Voice VLAN
    • DHCP
  • Phone has 3 port switch built into it
    • Port 1, connects to switch
    • Port 2, phone ASIC
    • Port 3, connects to PC

 


Power Over Ethernet, POE

  • Phones must receive power from a source
    • Switch POE
    • Power patch panel
    • POE injector
    • Power brick
  • POE is the ability to send electricity over ethernet
    • Centralized power distribution
      • Switches are generally on some type of backup power (UPS, generator)
    • Don’t need a power outlet at the phone
      • Outlets may not be where phones are being places
  • Standard, IEEE
    • 802.3af
      • 15-25 watts
    • POE+
      • 802.3at, 51 watts

 

Output from a switch

Home_Switch#sh power inline 

Available:124.0(w)  Used:12.0(w)  Remaining:112.0(w)

Interface Admin  Oper       Power   Device              Class Max

                            (Watts)                            

--------- ------ ---------- ------- ------------------- ----- ----

Fa0/1     auto   off        0.0     n/a                 n/a   15.4 

Fa0/2     auto   off        0.0     n/a                 n/a   15.4 

Fa0/3     auto   off        0.0     n/a                 n/a   15.4 

Fa0/4     auto   off        0.0     n/a                 n/a   15.4 

Fa0/5     auto   off        0.0     n/a                 n/a   15.4 

Fa0/6     auto   on         12.0    IP Phone 7945       3     15.4 

Fa0/7     auto   off        0.0     n/a                 n/a   15.4 

Fa0/8     auto   off        0.0     n/a                 n/a   15.4 

Home_Switch#

 


Voice VLAN

  • Cisco recommends having a dedicated vlan for voice
  • VLAN = Broadcast domain = IP Subnet
  • Trunk
    • Allow multiple vlans across a single physical interface
    • Also known as, tagging
    • 802.1q = standard
    • ISL = Cisco Proprietary
  • Voice vlan allows interface to become a multi-vlan access port
    • PC connects to phone, phone connects to switch
    • PC sends traffic untagged = access vlan
    • Phone sends traffic tagged = voice vlan
  • Phones receive voice vlan information through CDP neighbor
  • Configuration, switch

*Create layer 2 vlan on the switch

vlan <#>

name DATA

vlan <##>

name VOICE

!

spanning-tree bpduguard enable —> This command is not referenced in the book, but I mention it here as a best practice. This is a global command that will affect portfast enabled ports. BPDU Guard disables any interface that receives a BPDU into the interface. This is helpful is someone decides to create a loop by plugging in both ethernet ports on the phone into the switch

!

*Configure interface connected to a phone

interface <int> —> Go into the interface configuration

switchport access vlan <#> —> assign the access (data) vlan to the interface

switchport voice vlan <##> —> assign the voice vlan to the interface

spanning-tree portfast —> immediately bring interface into forwarding state, bypass spanning-tree listening and learning states

switchport mode access —> statically configure the interface as an access port. Default is to dynamically determine based on what plugged into the interface. Could either be trunk or access

Home_Switch(config)#vlan 20

Home_Switch(config-vlan)#name VOICE

Home_Switch(config-vlan)#exit

 


Phone Boot Process

  1. Phone connects to ethernet, if switch supports POE, the phone powers on
  2. Switch delivers voice vlan to phone through CDP. Phone starts tagging traffic with correct vlan information
  3. Phone broadcasts a DHCP Request
    1. Broadcasts are contained within a layer 3 vlan. Configuration can be added to the layer 3 SVI (Switches Virtual Interface) to relay DHCP request to a DHCP server if the server lives on a different subnet. ip helper-address <ip>
    2. Asks for an IP on it’s voice vlan
  4. DHCP server respinds with DHCP Offerr
    1. Phone access the offer if there is no duplicate address
    2. Offer contains: Default gateway, DNS Information, domain name
    3. Required from DHCP: Option 150. Option 150 contains information on the TFTP server, more on this later.
  5. Phone contacts TFTP server and downloads configuration file. The file contains valid CME or CUCM servers
  6. Phone registers with CME or CUCM

 


Router DHCP Configuration

  • DHCP is required for phones (and endpoints for that matter) to get an IP address and be able to communicate on the network
  • Below is an example configuration that can be done on a Cisco router

Global config:

ip dhcp excluded-address <start> <end>

ip dhcp pool <name>

network <ip> <subnet>

default router <ip>

dns-server <ip>

option 150 ip <ip>

Interface config:

interface vlan <int>

ip helper-address <ip>

 

Actual configuration

Home_Switch(config)#int vlan 20

Home_Switch(config-if)#ip add 192.168.20.1 255.255.255.0

Home_Switch(config-if)#ip helper-address 192.168.10.1

Home_Switch(config-if)#no shut

Home_Switch(config)#ip dhcp excluded-address 192.168.20.1 192.168.20.19

Home_Switch(config)#ip dhcp pool VOICE

Home_Switch(dhcp-config)#network 192.168.20.0

Home_Switch(dhcp-config)#default-router 192.168.20.1

Home_Switch(dhcp-config)#dns-server 192.168.10.1

Home_Switch(dhcp-config)#option 150 ip 192.168.10.200   

 


Network Time Protocol – NTP

  • Provides a clocking source
  • Display the correct time and date on phones
  • Get the correct date and time for voicemails
  • Accurate Call Detail Records (CDR), explained in later chapters
    • Track calls on the network
  • Security features
  • Tag log messages
  • Stratum levels, how accurate is the time source
    • Level 1 is the best

 

Configuration

ntp server <ip> —> where to get source of time from

clock timezone <timezone> —> What timezone is the device in

ntp master <stratum> —> Tells router to provide time

ntp server 192.168.10.1 prefer

clock timezone EST -5

clock summer-time EDT recurring

 


Phone Registration

  • Phones use SCCP or SIP for signaling
  • SCCP, Skinny
    • Cisco proprietary voice signaling protocol to control phones
  • SIP, Session Initiation Protocol
    • IETF standard voice signaling protocol
    • Lightweight alternative to H.323
  • Phones identify themselves with MAC address
    • Talks to CME or CUCM (call processors)
    • Call processor will send XML file to phone with its configuration
    • Configuration includes: device language, firmware version, call processing IPs, ports #s, etc.
      • Softkey layout
  • Signaling protocol is used for majority of phone functionality
    • Dial tone, digit collecting, on/off hook conditions

 


Quality of Service – QOS

  • For VOIP to operate successfully, voice must have priority over data traffic
  • QOS definition: Ability for the network to provide better or special service to a set of users and application at the expense of other users and applications
  • Voice traffic is time sensitive
  • Voice should get first access to bandwidth
    • Router queues other traffic in time of congestion
  • Problems QOS is trying to solve
    • Lack of bandwidth
    • Delay
    • Fixed delay
    • Variable delay
    • Jitter (delay variation)
    • Packet loss
  • Voice Traffic Requirements
    • Voice is predictable, if you know which codec is being used you’ll be able to calculate how much bandwidth is required
    • These are the maximum thresholds, lower is better
      • End to end delay – 150ms
      • Jitter – 30ms
      • Packet loss – 1%
    • Video has same requirements, just requires more bandwidth

QOS Mechanisms

  • Best Effort – Default, no QOS
    • First come, first serve
  • IntServ – Reservation Model
    • Resource Reservation Protocol (RSVP)
    • Provides guaranteed bandwidth
    • Has scalability problems, each router must track the traffic flow
  • DiffServ – Most popular and flexible model
    • Configure every device to respond with a variety of QOS methods based on traffic classes
    • DSCP
    • Note: This CCNA does not go into the level of detail that I was expecting. I’ll write up another post that’ll be a more in-depth on QOS

QOS Tools

  • Classification and Marking – Identify and mark packets
  • Congestion Management – QOS Queuing strategies
  • Congestion Avoidance – Drop packets before congestion occurs
  • Policing and Shaping – Give hard or soft limits on how much of a specified traffic is allowed
  • Link Efficiency – compression mechanisms

CCNA Collab book goes into Link Efficency and Queuing Algorithms. If you want to know about the others, drop a comment and I’ll write some more details around the others

Link Efficiency

  • Payload compression
    • Compress app data from being sent across the WAN
  • Header compression
    • Eliminate redundant fields of the header
    • RTP Header Compression, compressed RTP (cRTP). Go from 40 bytes down to 2 bytes, 4 bytes with error correction
  • Link Fragmentation and Interleaving – LFI
    • Addresses serialization delay by chopping larger packets into smaller ones
    • Used on PPP or frame relay connections

Queuing Algorithms

  • WFQ – Weighted Fair Queuing
    • Tries to balance available bandwidth for all senders
    • Default on serial interfaces
  • CBWFQ – Class Based WFQ
    • Guarantees specific amounts of bandwidth for various traffic classes
  • LLQ – Low Latency Queuing
    • Add a priority queue
    • Similar to CBWFQ

Applying QOS

  • Input Actions
    • Classification
    • Marking
    • Policing
  • Output Actions
    • Congestion management
    • Marking
    • Congestion avoidance
    • Shaping
    • Policing
    • Compression
    • Fragmentation and Interleaving

 


AutoQOS

  • Simplified mechanism to deploy QOS
  • Deploys template based on Ciso’s QOS best practice
  • Uses CDP to detect IP phone to apply QOS settings

AutoQOS Benefits

  • Reduced time to deploy
  • Configuration consistency
  • Reduced deployment cost
  • Allows manual tuning

AutoQOS, steps before deployment

  • Establish trust boundary – which endpoints do you trust markings from
  • Devices can mark traffic with different QOS classification
  • Ex: Phone marks all traffic as high priority (EF)
    • Note, DSCP was not covered in this book. I’ll write a future blog post
  • Phone has ability to strip marking PC’s set

AutoQOS Config

  • Single command under interface
  • Does not need to be applied on every device
    • This is according to the book. Real life, deploy QOS everywhere in a controller maner
  • Before commands are entered, check to make sure bandwidth statements are correct
  • AutoQOS uses a LLQ model

Global Config

Home_Switch(config)#auto qos ?

  srnd4  QoS configurations based on solution reference network design 4.0

Interface

Home_Switch(config-if)#auto qos ?

  classify  Configure classification for untrusted devices

  trust     Trust the DSCP/CoS marking

  video     Configure AutoQoS for video devices

  voip      Configure AutoQoS for VoIP

Home_Switch(config-if)#auto qos voip ?

  cisco-phone      Trust the QoS marking of Cisco IP Phone

  cisco-softphone  Trust the QoS marking of Cisco IP SoftPhone

  trust            Trust the DSCP/CoS marking

Home_Switch(config-if)#auto qos voip cisco-phone 

Home_Switch(config-if)#do sh run int fa0/7

Building configuration...

Current configuration : 226 bytes

!

interface FastEthernet0/7

 srr-queue bandwidth share 1 30 35 5

 priority-queue out 

 mls qos trust device cisco-phone

 mls qos trust cos

 auto qos voip cisco-phone 

 service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY

end

Home_Switch(config-if)#

Additional Output generated

!

class-map match-all AUTOQOS_VOIP_DATA_CLASS

 match ip dscp ef 

class-map match-all AUTOQOS_DEFAULT_CLASS

 match access-group name AUTOQOS-ACL-DEFAULT

class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS

 match ip dscp cs3 

!

!

policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY

 class AUTOQOS_VOIP_DATA_CLASS

  set dscp ef

  police 128000 8000 exceed-action policed-dscp-transmit

 class AUTOQOS_VOIP_SIGNAL_CLASS

  set dscp cs3

  police 32000 8000 exceed-action policed-dscp-transmit

 class AUTOQOS_DEFAULT_CLASS

  set dscp default

  police 10000000 8000 exceed-action policed-dscp-transmit

!

!

ip access-list extended AUTOQOS-ACL-DEFAULT

 permit ip any any

!

CCNA Collaboration – Notes, Chapter 2

CICD – Ch2 – Unified Collaboration

Unified Collaboration

  • More than just VOIP
  • Bring all collaboration into a seamless framework
    • Includes: voice, video and data
  • CICD covers core solutions
    • CME – Communications Manager Express
    • CUCM – Cisco Unified Communications Manager
    • CUC – Cisco Unity Connection
    • CUIMP – Cisco Unified IM and presences
  • There are more outside of this exam
    • Contact Center
    • WebEx
    • Telepresence
    • Spark

Communications Manager Express

  • Runs IP telephony on an ISR (integrated services router)
  • ISR can terminate analog and digital circuits
    • FXO, FXS, T1
      • FXO – Office, connects to POTS circuits
      • FXS – Station, connects to endpoints, analog phones, fax, modem
    • Supports VOIP endpoints
    • Features: conference calls, video, automatic call distribution
  • Platform dependent on number of supported phones
    • ISR4451, can handle 450 phones
  • All in one device for controlling phones and trunking to PSTN

CME Features

  • Call processing and device control
  • CLI or GUI based configuration
  • Local directory service
  • Computer Telephony Integration (CTI)
    • Control a device remotely. Example, have jabber make calls using your desk phone
  • Trunk to other voice systems
  • Integration with Unity Express
    • Runs on modules installed in router
    • Provides voicemail features

CME and IP Phones

  • CME controls virtually every action performed on phone
  • SCCP (skinny) or SIP used for signaling protocols to allow CME to communicate and control the phone
  • CME instructs phones where to connect, establish calls
    • Not involved in the RTP stream of traffic
    • CME is not required after a call has been setup
    • Exception: If call is going to PSTN that is attached to the CME router

CUCM

  • Linux based, VMware guest
  • Provides core device control, call routing, permissions, features, connectivity to outside applications
  • GUI based administration

CUCM Key Features

  • Full audio and video support
  • Appliance based operation
  • VMware install, on supported hardware
  • Redundant server cluster
    • Single CUCM cluster can handle 40000 phones running SIP or SCCP
    • Megacluster can handle 80000 phones
  • Intercluster trunk and Voice Gateway control
  • Built in disaster recovery
    • Done through sFTP
  • Directory service support and integration
    • Built-in or LDAP
  • Database replication
    • Publisher replicates read-only database to subscribers in the cluster
  • Run Time Data
    • Intercluster communication signaling (ICCS)
    • All servers in cluster form TCP connectionn for ICCS over TCP ports 8002-8004
    • Assuming 10,000 busy hour calls = 1.5Mbps per server
  • Changes to database are performed on Publisher
  • Standard cluster supports single publisher and 19 subscribers
    • 8 for call processing
  • 11 other subscribers can be TFTP, conference bridge, MOH, annunciater
  • TFTP is critical for phone and gateway operations
    • Bulk of config is downloaded from TFTP
  • Best practice is to pull publisher out of all call processing and let subscribers do the work
  • Phones can list 3 redundant CUCM servers for failover purposes

Unity Connection

  • Make any message retrievable from any voice enabled device or application
  • Supports 20000 voicemail boxes
  • Runs as VMware guest
  • Active / Active setup, publisher, subscriber
  • Features
    • Personal call transfer rules, speech recognition

Unity Connection Key Features

  • Appliance based
  • 20k mailboxes per server (cluster?)
  • Access voicemail from anywhere
  • LDAP integration
  • Microsoft Exchange support
  • Voicemail Profile for Internet Mail (VPIM)
    • Integration of voicemail services from difference vendors
  • Active / active high availability
    • Publisher / subscriber cluster
    • Both accept client requests
  • CUCM + CUC communicate using SCCP or SIP

IM and Presence – IMP

  • Jabber client
  • Shows full presence status
  • Enterprise instant messaging
    • Jabber, Extensible Communication Platform (XCP)
    • Industry standard, works with different IM clients
  • Message compliance
    • Logging
    • Encryption with TLS
  • Interdomain federation
    • Connects to other domains outside of your business
    • Business to business communication
  • Secure Messaging
    • TLS, IPSec
  • Jabber XCP extensibility
    • File sharing, app sharing, video conferencing
  • IMP integrated with CUCM supports 45000 users
  • IMP, IM only – 75000 users
    • No integration with CUCM

Jabber

  • IM Client: peer to peer client, multiuser chat, persistent chat
  • LDAP integration
  • Integrated with CUCM, able to see On/Off hook status
  • Start voice and video calls (HD)
  • Soft phone
  • CTI support, control desk phone from jabber client

Video Communication Server (VCS) + Telepresence Management Suite (TMS)

  • Call types
    • Internal desktop calls
      • Between 2 endpoints with camera
      • Registered to CUCM
    • Telepresence Calls
      • Using TP endpoints
    • External Video Calls
      • Business to business

VCS Control

  • Self contained video endpoint call control system for customers without CUCM

VCS Expressway

  • 2 servers – communicate as a trusted relationship
    • Core – inside firewall
    • Edge – deployed in DMZ
    • Perform firewall traversal
    • Allows callers to signal CUCM to setup video call with endpoints registered to CUCM

TMS – TP Management Suite

  • Manages scheduling of TP Meetings
  • For administrators
    • Provisioning tool to deploy TP endpoints across multiple locations within organization
    • Central admin of all TP infrastructure resources
    • Real time management of all conferences
    • Phone book sync
    • Reporting
  • For users
    • Ease of scheduling
      • Outlook / exchange integration
      • one button to push
    • Contact – phone book from multiple sources

CCNA Collaboration – Notes, Chapter 1

These notes are based on reading the official certification guide “CCNA Collaboration CICD 210-060 Official Cert Guide“.

 

CICD – Ch1 – Traditional Voice vs. Unified Voice

Analog Voice

Analog Signal

  • Electrical voltage, frequency, current and charge used to convey properties of voice

Analog Phone Lines

  • Uses properties of electricity to convey changes in voice over cabling
  • Must convey signaling
    • Dial tone, dialed digits, busy

Analog Circuit

  • Pair of wires
    • Ground (positive) – TIP
    • Negative (battery) – RING
    • Where concept of TIP and RING comes from

Loop Start Signaling

  • 2 wire phone with 48v DC current
  • Typically found in home environments
  • Problem – Glare
    • Occurs when going to pick up phone off hook and at the same time a call comes in before the phone can ring

Key System – PBX

  • Have chance of glare occurring

Modern PBX

  • Found in larger corporate environments
  • Ground start signaling
    • Originated by the pay phone
    • Allows PBX to separate an answering phone from incoming phone line

Supervisory Signaling

  • On hook, off hook, ringing
  • Informational signaling
    • Dial tone, busy, ring back
  • DTMF – Dual Tone Multi Frequency

Analog Signal Problems

  • Degraded over distances, signal loss
  • Repeaters installed to increase distance
    • Regenerated the signal
    • Could not differentiate between voice on wire vs. line noise
    • Line noise would be amplified
  • Number of wires the phone company needed to run and maintain
    • Each phone required 2 wires
    • Bundles of wires hard to maintain

Digitizing Voice

  • Process of changing analog voice signal into a series of numbers
  • Digital transmission eliminated need for individual pair of wires required for analog connectors

Traditional Digital

  • TDM, Time Division Multiplexing
  • Digital encode multiple conversations over a single 4 wire path
  • Numeric value transmitted in specific time slots
    • Different conversations

T1 Circuit (US, Canada, Japan)

  • 24 separate 64 kbps channels
    • DS0
  • Each channel supported 1 voice call

Channel Associated Signaling – CAS

  • Signaling information is transmitted in the same channel as voice
  • Robber bit signaling – RBS
    • Steals a bit from voice channel to transfer signaling information
  • T1 uses 8th bit of every 6th sample / frame

Common Channel Signaling – CCS

  • Dedicated one DS0 from T1/E1 for signaling
  • Out of Band (OOB) signaling
    • Signal is completely separate from voice traffic
  • T1 has 23 usable DS0’s for voice
  • Signaling protocol – Q.931
    • Used on ISDN circuits
    • SS7 signaling for CCS between CO’s
  • Allows PBX vendors to communicate proprietary messages and features between PBX systems using ISDN
  • T1 uses 24th slot
  • E1 uses 17th slot

PSTN – Public Switches Telephony Network

  • Establish world wide pathways to allow people to easily connect, converse and disconnect
  • Components
    • Analog phone
      • converts audio to electrical and vice versa
      • Connects to PSTN
    • Local Loop
      • Link between customer and service provider
    • CO Switch
      • Provides services to devices on local loop
      • Signaling, digit collection, call routing, setup and teardown
    • Trunk
      • Connection between CO Switches
    • Private Switch
      • Miniature PSTN inside company
      • PBX?
    • Digital Phone
      • Connects to PBX
      • Converts audio into binary

PBX – Private Branch Exchange

  • Manage in-house phones (business)
  • Allow internal calls without using PSTN resources
  • Connects internal phones and connects to PSTN
  • Components
    • Line Cards
      • Provides connection between phones and PBX
    • Trunk Card
      • Provides connection from PBX to PSTN or other PBX’s
    • Control Card
      • Intelligence of PBX
      • All call setup, routing and management functionality
  • Key System
    • Geared for smaller environments (50 users or less)
    • Fewer features, more of a shared line feel
  • Connections to PSTN
    • CCS style signaling
    • Call setup, routing, billing, informational messages
    • Call > CO > # lookup > forward to destination

PSTN Number Plans

  • Must use valid E.164 standard address
  • E.164 is international number plan created by International Telecommunications Union (ITU)
    • Limited to max of 15 digits
  • Components
    • Country Code
    • National Destination Code
    • Subscriber number

VOIP – Voice over IP

  • Send voice traffic over data network
  • Concerns
    • Ensuring packets get to destination intact and quickly (QoS)
    • Coding / Decoding (Codec)
    • Security, not snooped or changed in transit (Encryption)
  • Benefits
    • Reduced cost of communications
      • Use existing WAN/Internet for calls
      • No toll charges
    • Reduced cabling
      • Run single ethernet to desk
    • Seamless Voice Networks
      • Uses business network, not PSTN
      • Central control of all voice devices
      • 4 digit dialing across the world
    • Reduced cost of MACD
    • Softphone
    • Unified email, voicemail and fax
    • Increased productivity
      • Ring all devices
    • Feature rich
    • Open standards

Converting voice to packets

  • Dr Harry Nyquist – created mathematical foundation to convert analog signals (flowing) waveforms into digital format (binary)
  • 3 Step Process (optional 4th)
    • Samping
    • Quantization
    • Encoding
    • (optional) Compression
  • Audio Frequencies
    • Human ear can hear > 20 – 20,000 Hz
    • Human speech > 200 – 9,000 Hz
    • Traditional phone transmits > 300 – 3,400 Hz
    • Standard equipment to digitize human speech > 300 – 4,000 Hz
  • Nyquist
    • Sample twice the highest frequency (2×4000)=8000
    • Sample = 1 byte, 8 bits
    • 8000 samples per second, times 8 bits for each sample
      • Product = 64,000 bits per second
      • This is uncompressed audio
      • G.711 – 64kbps
    • Once sampling assigns a numeric value to all analog signals traffic gets encapsulated
      • UDP and RTP (real-time transport Protocol)

Codecs

  • 2 main codecs on all Cisco IP Phones
  • Compression, reduce amount of bandwidth required for a call
  • MOS – Mean Opinion Score
    • Quality of various voice codecs
  • G.711
    • Common on all VOIP devices
    • 64 kbps per call
  • G.729
    • Compressed audio
    • 8 kbps
    • 2 Variants
      • G.729a (annex A) – sacrifices audio quality for better processor efficient coding
      • G.729b (annex B) – introduces VAD (voice activity detection), makes voice transmission more efficient
  • G.722
    • Default on new Cisco phones
    • Wideband codec
      • Reproduces a wider range of frequencies
      • Better audio
    • 64 kbps

Digital Signal Processor – DSP

  • Offload processing for voice related tasks from the routers processor
  • Chip that performs all sampling, encoding and compression functions on audio / video coming into the router
  • Packet Voice DSP Module (PVDM)
    • Memory stick
    • Comes in different sizes
  • Codecs consume DSP resources
    • Some consume more than others
    • DSP resources can handle (approx) double the number of medium complexity calls per DSP than high complexity

Real-time Transport Protocol – RTP

  • Operates at transport level of OSI model
    • UDP based traffic, does not require acknowledgement
  • UDP provides port numbers and header checksum
  • RTP adds timestamps and sequence numbers to header information
  • Random port – 16,384 <> 32,767
    • Always even number
  • Devices setup point to point RTP stream, one in each direction

Real-time Transports Control Protocol – RTCP

  • Reports statistics between 2 devices in the call
    • Packet count
    • Packet delay
    • Packet loss
    • Jitter (delay variations)
  • UDP based traffic
    • Random port – 16,384 <> 32,767
      • Always odd number
  • Separate session from RTP
  • Devices send RTCP packet once every 5 seconds